Tags

arm arpaname bin_sh blocage blosxom bsd bsdfrance cblog certification chroot cluster dg834 dhcp dns dnsmasq domU dovecot fail-over fail2ban firefox freebsd ftp git guruplug install ipv6 jail kernel kimsufi lex libre linutop makefile mikrotik ml150 mohawk netbook netbsd nginx ntp ntp.org openbsd openntpd openrd openwrt orke pkgng poudriere proxy python rescue reverse rmll route rrdcgi sendmail sieve sl2009 ssd symon update usb var_empty vimperator world xen yacc zfs

Powered by

blOg
maRkdown
awK
shEll

14/09/2013

[ mikrotik ipv6 ]

201309141045 mikrotik ipv6

Mikrotik RB951G-2HnD et l'ipv6 de chez Free

Mon nouveau routeur est un mikrotik routerboard RB951G-2HnD. Je dois dire que j'en suis pleinement satisfait:

Mon FAI (celui qui a tout compris) n'avait pas très bien compris les règles d'attribution d'adresses ipv6 et m'accordait généreusement un unique /64. De son côté Hurricane Electric propose un /48 par tunnel, ce qui contre-balance l'inconvénient d'une connectivité ipv6 au travers de paquets ipv4.

Mon FAI a revu (légèrement) sa copie et accorde désormais un /61, ce qui correspond à 8 sous réseaux:

A la lecture de ce post, j'en retiens qu'il faut absolument connaitre l'adresse lien local de la box. Pour se faire, une fois activé l'option 'IPv6' depuis mon interface de gestion, j'ai simplement branché mon vénérable netbook et son OpenBSD 5.4 et un sudo tcpdump -n -i re0 icmp6 plus tard, je pouvais commencer la configuration de mon routeur (bien qu'un /tool sniffer quick interface=ether1-gateway ip-protocol=icmpv6 aurait sans doute été plus simple, mais j'ai découvert cette fonctionnalité trop tard, tout comme /ipv6 neighbor print).

Le routeur est configuré comme suit:

/ipv6 address add interface=ether1-gateway address=2a01:xxxx:yyyy:zzz0::2/64
/ipv6 address add interface=wlan1 address=2a01:xxxx:yyyy:zzz2::1/64 advertise=yes
/ipv6 route add dst-address=::/0 gateway=adresse_lien_local_de_la_box%ether1-gateway

Attention à la syntaxe: adresse lien local suivi du caractère '%' suivi du nom de l'interface. Pour mémoire, l'adresse 2a01:xxxx:yyyy:zzz0::1/64 est utilisée par la box. Pour une raison que je ne m'explique pas je peux pinguer cette adresse uniquement depuis l'extérieur (pratique lors des tests).

Pour finir, les points forts et faibles de FAI versus Hurricane Electric:

FAI bien:

FAI pas bien:

Hurricane Electric bien :

Hurricane Electric pas bien:

Ma conclusion personnelle: Hurricane Electric oeuvre à la promotion de l'ipv6 et mérite tout mon respect. Mais une solution à base de tunnel n'est qu'un pis-aller en attendant de pouvoir bénéficer d'une connectivité native. Si mon FAI me donne l'impression de balbutier la fourniture d'un accès ipv6 grand public (6to4rd puis /61 natif, toujours pas de délégation de préfixe) je ne lui en veut pas: proposer de l'ipv6 est louable et quant bien même la réalisation laisse à désirer, elle mérite d'être encouragée.

Ps: M. Niel, serait-il possible pour ce noel 2014 d'avoir une délégation de préfixe et au moins un /56 (quitte à ce que vous vous réserviez plusieurs /64 pour le bon fonctionnement de vos box) ?


Lien vers ce billet